fr

Problèmes Spektrum DX8 | Forum

Emplacement du sujet : Accueil du forum » Technique » Radiocommandes
Carpaccio
Carpaccio Fév. 3
Bonjour à tous, 

toujours avec mes soucis de réglages, je m'explique:


Dès que je règle le THRO avec ma radio (DX8) sur 1000, au mini, (dans BF) je n'arrive plus à armer le drone, je suis obligé de descendre bien en dessous de cette valeur pour armer.
Les réglages sont les suivants:
ESC (sous Bel Heli) 1012 / 2000.


# master
set acc_trim_pitch = 6
set acc_trim_roll = 2
set acc_calibration = 77,93,-235
set mag_hardware = NONE
set baro_hardware = NONE
set min_check = 1000
set max_check = 2000
set serialrx_provider = SPEK2048
set min_throttle = 1000
set motor_pwm_protocol = MULTISHOT
set failsafe_delay = 10
set failsafe_procedure = AUTO-LAND
set 3d_deadband_throttle = 10
set small_angle = 30
set deadband = 5
set yaw_deadband = 5


Bien évidemment out cela donne un comportement pas très sain, moteurs  qui tournent avec les gaz aux minis, puis qui s'emballent des que je touche au pitch ou au yaw, même quand le stick revient au neutre.

J'ai bien lu le tuto des réglages sur mini raccer.  !!!


Par avance merci :)


Mes réglages dans BF :






Ce message du forum a été modifié par Steven Fév. 3
Steven
Steven Fév. 3
Y'a quelque chose qui me choc de suite c'est que tu utilise le Multishot, avec les ESC EMAX Bullet Series tu doit choisir le DSHOT 600.

Cela étant fait, la valeur du min_throttle doit être supérieure à min_check, généralement 1150 mais ça dépend de tes moteurs.   


PS: J'ai édité ton post pour plus de clarté, stp évites le multipost, rassemble toutes tes questions ou réponses dans un seul post, merci ;)

Ce message du forum a été modifié par Steven Fév. 3
Carpaccio
Carpaccio Fév. 3

merci pour ton retour.

et désolé je ne suis pas très à l'aise sur les forums et les posts 


avec ces réglages, il n'arme plus ?? 

Ce message du forum a été modifié par Steven Fév. 3
Steven
Steven Fév. 3
Les Bullet series ont le protocole DSHOT 600 donc tu ne pourra pas faire autrement.

Retape la commande "status" dans l'onglet CLI histoire de voir ce qui gêne maintenant.

N'oublies pas qu'on ne peut pas armer avec la radio quand le quad est connecté à BF.


J'ai sensiblement la même config que toi en ce qui concerne les ESC et les moteurs mais pas la radio.

Mes réglages sont:

min_check = 1050

max_check = 1900

min_throttle = 1070

max_throttle = 2000

min_command = 1000

Dans l'onglet configuration la valeur des gaz dans la partie DSHOT est de 4.5

Motor Stop est désactivé car le Air mode est activé.


Ne désepère pas, ça fait beaucoup de notions à intégrer pour un débutant, plus tard ça viendra tout seul...



Carpaccio
Carpaccio Fév. 3
c'est cool, je test et reviens vers toi. ;-))
Carpaccio
Carpaccio Fév. 3
 Status:


$M>lùÿlEnteringCLIMode,type'exit'toreturn,or'help'#status
System Uptime: 20 seconds
Current Time: 2019-02-03T19:38:07.470+00:00
Voltage: 0 * 0.1V (0S battery - NOT PRESENT)
CPU Clock=168MHz, Vref=3.34V, Core temp=45degC, GYRO=MPU6000, ACC=MPU6000
SD card: Startup failed
Stack size: 2048, Stack address: 0x1000fff0
I2C Errors: 0, config size: 2562, max available config: 16384
CPU:8%, cycle time: 126, GYRO rate: 7936, RX rate: 90, System rate: 9
Arming disable flags: THROTTLE CLI MSP

Steven
Steven Fév. 3
Selon la doc de BF ta valeur min_throttle est trop élévée.

Quelle sont tes valeurs min_throttle et min_check maintenant ?

Entres la commande "get min_throttle" puis "get min_check" dans l'onglet CLI pour le savoir. 

Ce message du forum a été modifié par Steven Fév. 3
Carpaccio
Carpaccio Fév. 3
ok, donc avec T réglages: le drone arme sans Pb, et au démarrage les moteurs tournent, est-ce normal ? 

j'ai essayé de désactiver airmod et d'activer MotorStop, les moteurs tournent également.


$M>ni$M>lòÿþÿgEnteringCLIMode,type'exit'toreturn,or'help'# get min_throttle
min_throttle = 1070
Allowed range: 750 - 2250

pid_at_min_throttle = ON
profile 0
Allowed values: OFF, ON


# get min_check
min_check = 1050
Allowed range: 750 - 2250

Ce message du forum a été modifié par Steven Fév. 3
Steven
Steven Fév. 3
C'est normal que les moteurs tournent au ralenti avec le Air Mode activé mais pas avec Motor-Stop activé.

Le Air Mode est activé par défaut maintenant c'est un Must Have, mais il faut s'assurer d'avoir paramétré un double armement pour éviter les accidents.


En fait je pense que tu devrais d'abord régler correctement les Ends Points de ta radio, cette page pourra t'aider. En anglais içi.


Pour le code Arming disable flags: THROTTLE CLI MSP, selon la doc de BF la valeur de min_throttle doit être inférieure à celle de min_check.


Les nouvelles versions récentes de BF ont sans arrêt de nouvelles fonctions pour améliorer la sécurité, c'est bien mais du coup on est vite perdu si on le met pas jour régulièrement...

Carpaccio
Carpaccio Fév. 3
c'est bon avec l'airmod désactivé et motor stop actif, c'est bon !!

oufff



Steven
Steven Fév. 3
Ok mais quand tu arme le quad avec motor_stop activé, si les moteurs tournent ce n'est pas normal.

Quand tu débute tu peux faire l'impasse sur le air mode, mais quand tu attaquera les figures il sera indispensable.


Autre chose, n'oublies pas de souder le condensateur fourni avec ta Matek F405 et surtout attention à la polarité !


Carpaccio
Carpaccio Fév. 3
c'est tout bon: moteurs et condo!

petit test demain soir, je te tien informé. un grand merci pour ton aide !


Steven
Steven Fév. 3
De rien, content d'avoir pu t'aider ;)
Carpaccio
Carpaccio Fév. 4
bonsoir Steven,


j'ai donc essayé le drone ce soir, 2 lipos, c'est cool pour un début ...Meme s'il fonctionne plutôt bien, il a tendance a tiré un peut a droite. Il faut donc peaufiner les réglages. 

Je vais continuer à me documenter sur le sujet, 
Je vais également changer de radio pour une TARANIS et acheter une paire de Fatshark,(le tout d'occasion) histoire d'être équipé complètement. J'ai hâte de voler en FPV.
Merci pour ton aide.



Ce message du forum a été modifié par Carpaccio Fév. 4
Steven
Steven Fév. 4
Première chose à faire poser bien à plat ton quad et cliquer sur le bouton "calibrer l'accéloromètre" dans l'onglet "Instalation" de BF.

Je viens de m'offrir la Taranis XLite, c'est une très bonne radio bien moins chère que la X9D et tout à fait convenable.

Pour les lunettes si tu veux pas te ruiner les Skyzone V2 ou les Eachine V200 tiennent la route. 

Carpaccio
Carpaccio Fév. 4
ok merci, je vais regarder..Peux tu me dire à quel moment il faut arrêter de tirer sur les lipos ? 


Ce message du forum a été modifié par Steven Fév. 4
Steven
Steven Fév. 4
14V c'est la limite de sécurité sur une lipo 4s soit 3.5v par cellule.

En dessous de 13V2 soit 3.3v par cellule tu détruit irrémédiablement ta lipo.

Carpaccio
Carpaccio Fév. 4
donc retour osd obligatoire !!

merci